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1. Overview 

1.1 Introduction 

This chapter defines the Kernel Overview Manual Validation Procedure and is part of 
the required set of test procedures to be used in the certification of products to The 
Open Brand COE Platform Product Standard1.  

2. Test Purpose 

2.1 Scope  

This test procedure provides a high level test of the full range of fundamental Kernel 
Platform functionality.  Each of the other COE Platform Compliance tests provides a 
deeper (i.e. more thorough) test of specific narrower range of Kernel functionality.  
This test also assures that the Graphical User Interface (GUI) presented to the user 
for basic system operation is consistent across all compliant systems certified to the 
COE Platform Product Standard.  This test also assures that the operations invoked 
and exercised have identical results and that they are consistent across all compliant 
systems. 

2.2 Description of test items  

Functionality that will be tested using the Kernel Overview Validation Procedure is as 
follows: 

sysadmin login - Verify sysadmin login, Profile Selector, Change Password Tool, 
command line accessibility, and icon accessibility 

Adm Tool - Invokes the native operating system's administration tool. On Solaris, 
the Adm Tool icon invokes the Solaris admintool application.  

Change Machine ID (with DNS) - Allows the System Administrator to change the 
machine name or Internet Protocol (IP) address of the workstation. 

Create Action - Allows the System Administrator to create a desktop action. 

Dtterm - Opens a dtterm terminal window for the System Administrator to perform 
tasks that require the use of a command line. 

Disk Manager - Allows the System Administrator to perform file system 
management tasks, including mounting and exporting file system partitions, 
formatting hard drives and hard drive partitions, displaying available hard disk 
space, and initializing diskettes. 

 

                                           
1 See http://www.opengroup.org/openbrand/coe/ 
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Edit Local Hosts - Allows the System Administrator to manage the local host table, 
which lists the computers that can be accessed from the local workstation. 

Network Installation Server and Segment Installer - Allows the System 
Administrator to load software segments onto a machine and make them available 
for other computers to install. Allows the System Administrator to install and/or 
remove software segments on the local workstation. 

Set Routes - Allows the System Administrator to configure the workstation to 
connect to the wide area network through a default router. 

Set System Time - Allows the System Administrator to set or change the value of 
the system time. 

Text Editor - Invokes a text editor application. 

Xterm - Opens an xterm terminal window for the System Administrator to perform 
tasks that require the use of a command line. 

Reboot System - Allows the System Administrator to reboot the machine. 

Shutdown System - Allows the System Administrator to prepare the machine for 
powering down. 

secman login - Verify secman login, Profile Selector, Change Password Tool, 
command line accessibility, and icon accessibility 

APM Client - Invokes the Account and Profile Manager client application. The APM 
Client administers user accounts, groups, profiles, and hosts. 

APM Server Reload - Shuts down and restarts the APM local server process 

APM Server Stop - Shuts down the APM local server process. 

APM Server Start - Restarts the APM local server process if the Security 
Administrator has shut it down. The APM local server communicates with the APM 
client and the APM master server to perform administrative operations. 

Assign Passwords - Allows the Security Administrator to assign passwords to user 
accounts. This operation requires root access to the system. 

Audit Log File Manager - Allows the Security Administrator to manage the audit 
log files, which record user login and logout information. 

Edit APM Configuration - Invokes a graphical tool that allows the Security 
Administrator to edit the APM configuration settings. 

Set Local Authentication Key � Uses the keyman account to set the local 
authentication key for the Candidate Platform and inform the Validation Host of the 
key. 

Merge Host - Copies and synchronizes APM account and profile information from an 
APM host server to the APM master server. This operation adds an APM host to the 
APM administrative domain. 

Profile Selector Configuration - Configures settings for the Profile Selector 
application. 

Remove Host - Removes a merged host from the APM administrative domain. 
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 Public Key Manager � Exports the host�s public key to a text file or imports the 
public key of a remote host. 

Logout. 

 

2.3 Test Data/Media Required   

The following segments are required to execute this test: 

OnlineDocs Segment Version 4.2.0.0. 

2.4 Setup/Equipment Required 

This test requires a Validation Cell consisting of a Validation Host and Candidate 
Platform.  

2.5 Required Personnel 

A single (1) tester will be required. The tester must be familiar with POSIX/UNIX 
application platforms, but need not be familiar with the Common Operating 
Environment (COE). 

2.6 Change History 

June 02, 2003 

Initial Release 

 

 

 

 

 



 

  

3. Test Procedure Submission Form 

 

Test Title: Kernel Overview Validation Procedure 

 

Candidate Platform:     Date:   

Tester:      Estimated Runtime: 6 hours  

Start Time:   End Time:   Actual Runtime:   

Test Site/Organization:     Overall Test Result (Circle One): PASS / FAIL 

 

Configuration Validated 

Hardware Platform:      System Software:    

Network Type:      Printer:    

Local Devices (if any):        

 

 



 

  

 

4. Test Procedure 

Start of Validation Procedure 

 Operator Action Expected Result Observed Result 

 Note -> Sections A1.1 through B1.2 should be executed prior to installing any additional segments or setting up DNS. 

A 
4.1 Verify sysadmin Login, Profile Selector, Change Password Tool, Command Line Accessibility, and Icon 

Accessibility 

A.1 Verify sysadmin Login  

A.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Verify that the DII COE LOGIN screen appears. 

The DII COE LOGIN screen appears with the 
DoD security warning message and the Please 
enter your user name text box. 

Circle one:  PASS / FAIL 

 

A.1.2 Log in as the System Administrator by typing 
sysadmin in the Please enter your 
user name text box and pressing ENTER. 

The password screen appears with the Please 
enter your password text box. 

Circle one:  PASS / FAIL 

 

A.1.3 Type the password for the sysadmin account in the 
Please enter your password text box and 
press ENTER.  

A dialog box appears indicating that the password 
needs to be changed. 

Circle one:  PASS / FAIL 

 

A.1.4 Click OK. A command line window appears with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 
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 Operator Action Expected Result Observed Result 

A.1.5 Enter the initial password. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 

 

 

A.1.6 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password: _____________ 

 

A.1.7 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

A.1.8 Log in as user sysadmin with the new password. An INFORMATIONAL MESSAGE dialog box 
appears confirming COE login processing is 
complete. 

Circle one:  PASS / FAIL 

 

 

A.1.9 Click OK in the INFORMATIONAL MESSAGE 
dialog box. 

The dialog box disappears. Circle one:  PASS / FAIL 
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 Operator Action Expected Result Observed Result 

A.2 
4.2 Verify sysadmin Profile Selector Functionality 

 

A.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

On the CDE, click Profile Selector (the 
head with a question mark). 

The Profile Selector window appears with 
SA Default listed in the Selected 
Profiles panel. 

Circle one:  PASS / FAIL 

 

 

A.2.2 Click Cancel. The Profile Selector window disappears. Circle one:  PASS / FAIL 

 

A.3 
4.3 Verify sysadmin Change Password Tool Functionality 

 

A.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

On the CDE, access the Change Password 
Tool by clicking the arrow above the Profile 
Selector icon.  

The DII Tools menu appears. Circle one:  PASS / FAIL 

 

 

A.3.2 Select Change Password Tool.  The Change your password window 
appears. 

Circle one:  PASS / FAIL 

 

A.3.3 Enter an incorrect sysadmin password in the Old 
Password text box. 

Asterisks appear in the text box. Circle one:  PASS / FAIL 

A.3.4 Enter a valid new password in the New 
Password and Password Confirm text boxes. 

Asterisks appear in the text boxes. Circle one:  PASS / FAIL 
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 Operator Action Expected Result Observed Result 

A.3.5 Click Submit. A Status Summary dialog box appears 
indicating the validation by sysadmin failed. 

Circle one:  PASS / FAIL 

 

A.3.6 Click OK. The Status Summary dialog box disappears. Circle one:  PASS / FAIL 

 

A.3.7 On the CDE, access the Change Password 
Tool by clicking the arrow above the Profile 
Selector icon. 

The DII Tools menu appears. Circle one:  PASS / FAIL 

 

A.3.8 Select Change Password Tool.  The Change your password window 
appears. 

Circle one:  PASS / FAIL 

 

A.3.9 Enter the correct sysadmin password in the Old 
Password text box. 

Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

A.3.10 Enter a new password in the New Password and 
Password Confirm text boxes. 

NOTE: This password change cannot be undone. 
All test personnel should be informed of the new 
password. 

Asterisks appear in the text boxes. Circle one:  PASS / FAIL 

 

 

A.3.11 Click Submit. A Status Summary dialog box appears 
indicating minimum password life has not expired. 

Circle one:  PASS / FAIL 

 

A.3.12 Click OK. The Status Summary dialog box disappears. Circle one:  PASS / FAIL 

 

A.3.13 On the CDE, click Exit. A Logout Confirmation dialog box appears. Circle one:  PASS / FAIL 
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 Operator Action Expected Result Observed Result 

A.3.14 Click OK. The dialog box disappears and the DII COE 
LOGIN screen appears. 

Circle one:  PASS / FAIL 

 

A.3.15 Login as sysadmin using the old password. The desktop appears. Circle one:  PASS / FAIL 

 

A.4 
4.4 Verify Command Line Access 

 

A.4.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Right-click on the desktop. 

The Workspace Menu appears. Circle one:  PASS / FAIL 

 

A.4.2 Select Tools > Terminal. 

NOTE: This method is OS specific. Use the 
relevant method on the OS being tested and note it 
in the Observed Result column. 

NOTE: This method should be used in all 
following test steps for the operator action �Open a 
Terminal window�. 

A Terminal window appears with a command 
line prompt. 

Circle one:  PASS / FAIL 

 

 

A.4.3 At the command prompt type 
id 

NOTE: This command is OS specific. Use the 
relevant command on the OS being tested and note 
it in the Observed Results column. 

The system returns 
uid=100(sysadmin) gid=1(other) 

NOTE: This result is OS specific. The result 
should indicate the user is sysadmin. 

Circle one:  PASS / FAIL 

 

 



© 2003, The Open Group 
Chapter 1, Page 12 

 
 

 

 

 Operator Action Expected Result Observed Result 

A.4.4 At the command prompt type 
pwd  

NOTE: This command is OS specific. Use the 
relevant command on the OS being tested and note 
it in the Observed Results column. 

The system returns 
/h/USERS/local/sysadmin/Scripts  

NOTE: This result is OS specific. The result 
should indicate the above path. 

Circle one:  PASS / FAIL 

 

 

A.4.5 At the command prompt type 
exit 

The Terminal window disappears. Circle one:  PASS / FAIL 

 

A.5 Verify Icon Access  

A.5.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Right-click on the desktop. 

NOTE: This method is OS specific. Use the 
relevant method on the OS being tested and note it 
in the Observed Results column. 

The Workspace Menu appears. Circle one:  PASS / FAIL 

 

 

A.5.2 Select Applications > Application 
Manager.  

NOTE: This method is OS specific. Use the 
relevant method on the OS being tested and note it 
in the Observed Results column. 

The Application Manager window appears. Circle one:  PASS / FAIL 

 

 

A.5.3 Double-click DII_APPS. The Application Manager – DII_APPS 
window appears. 

Circle one:  PASS / FAIL 
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 Operator Action Expected Result Observed Result 

A.5.4 Double-click SysAdm. The Application Manager – SysAdm 
window appears with the following icons: ..(go 
up), Adm Tool, Change Machine ID, 
Create Action, DTterm, Disk 
Manager, Edit Local Hosts, Network 
Installation Server, Reboot 
System, Segment Installer, Set 
DNS, Set Routes, Set System Time, 
Shutdown System, Text Edit, XTerm. 

Circle one:  PASS / FAIL 

 

 

B 
4.5 Verify Adm Tool Functionality 

B.1 Open the Adm Tool  

B.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Double-click Adm Tool. 

The Admintool:Users window appears.  

NOTE: This result is OS specific. The native 
operating system�s administration tool should be 
launched. 

Circle one:  PASS / FAIL 

 

B.1.2 Select File > Exit. The Admintool:Users window disappears. Circle one:  PASS / FAIL 
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 Operator Action Expected Result Observed Result 

 Note -> Prior to proceeding, all additional segments should be installed and the DNS 
configured on the candidate platform. 

C 
4.6 Change Machine ID Functionality  

C.1 Change the Machine  Name and IP Address Of the Workstation  

C.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click Change Machine ID in the 
Application Manager – SysAdm window. 

The Change Machine Id window appears. Circle one:  PASS / FAIL 

 

 

C.1.2 In the New Machine Name text box, enter 
nohost 

NOTE: If the /etc/resolv.conf file is 
installed on the system, the Change Machine ID 
tool checks the system's host name against the 
information in the Domain Name Service (DNS). If 
the System Administrator attempts to use the 
Change Machine ID tool to change the host name 
to one that is not found in the DNS, the machine ID 
will not be changed. 

nohost appears in the New Machine Name 
text box. 

Circle one:  PASS / FAIL 

 

 

C.1.3 In the New Machine Address text box enter 
10.0.0.1 

10.0.0.1 appears in the New Machine 
Address text box. 

Circle one:  PASS / FAIL 

 

C.1.4 Click Ok. An Input dialog box appears asking for the 
master APM authentication key. 

Circle one:  PASS / FAIL 
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 Operator Action Expected Result Observed Result 

C.1.5 Enter the master APM authentication key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

C.1.6 Click OK. A Error dialog box appears with the message: 
Could not change host ID! 

Unable to verify hostname and ip 
address with DNS. 

Circle one:  PASS / FAIL 

 

 

C.1.7 Click OK. The Error dialog box disappears. Circle one:  PASS / FAIL 

 

C.1.8 In the New Machine Name text box enter 
kpctest 

kpctest appears in the New Machine Name 
text box. 

Circle one:  PASS / FAIL 

 

C.1.9 In the New Machine Address text box enter 
204.34.175.193 

204.34.175.193 appears in the New 
Machine Address text box. 

Circle one:  PASS / FAIL 

 

C.1.10 Click Ok. An Input dialog box appears asking for the 
master APM authentication key. 

Circle one:  PASS / FAIL 

 

C.1.11 Enter the master APM authentication key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

C.1.12 Click OK. A Success dialog box appears with the message: 
Operation completed successfully. 

Reboot system now? 

Circle one:  PASS / FAIL 

 

 

C.1.13 Click Yes. The workstation reboots and the DII COE 
LOGIN screen appears. 

Circle one:  PASS / FAIL 
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 Operator Action Expected Result Observed Result 

C.2 Verify ID Change  

C.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Login as sysadmin. 

The desktop appears. Circle one:  PASS / FAIL 

 

C.2.2 Open a Terminal window. A Terminal window appears with a command 
line prompt. 

Circle one:  PASS / FAIL 

 

C.2.3 At the command prompt type 
cat /etc/hosts 

The contents of the /hosts file appear. Circle one:  PASS / FAIL 

 

C.2.4 Verify that the following line appears in the listing: 
204.34.175.193 kpctest loghost  

A line containing the specified information is 
present.  

The additional text “kpccp.kpc.disa.mil” 
may also be present. 

NOTE: Change Machine ID does not change 
aliases (i.e. kpccp.kpc.disa.mil). 

Circle one:  PASS / FAIL 

 

 

C.3 Restore the Machine Name and IP Address Of the Workstation  

C.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Click Profile Selector. 

The Profile Selector window appears with 
SA Default listed in the Available 
Profiles panel. 

Circle one:  PASS / FAIL 

 

C.3.2 Double-click SA Default. Profile SA Default moves to the Selected 
Profiles panel. 

Circle one:  PASS / FAIL 
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 Operator Action Expected Result Observed Result 

C.3.3 Click OK. The Profile Selector Results window 
appears indicating that SA Default has been 
successfully assumed. 

Circle one:  PASS / FAIL 

 

C.3.4 Click Done. The Profile Selector Results window 
and Profile Selector window disappear. 

Circle one:  PASS / FAIL 

 

C.3.5 Select Applications > Application 
Manager > DII_APPS > SysAdm. 

The Application Manager – SysAdm 
window appears. 

Circle one:  PASS / FAIL 

C.3.6 Double-click Change Machine ID. The Change Machine Id window appears. Circle one:  PASS / FAIL 

 

C.3.7 In the New Machine Name text box, enter 
kpccp 

kpccp appears in the New Machine Name text 
box. 

Circle one:  PASS / FAIL 

 

C.3.8 In the New Machine Address text box enter 
204.34.175.195 

204.34.175.195 appears in the New 
Machine Address text box. 

Circle one:  PASS / FAIL 

 

C.3.9 Click Ok. An Input dialog box appears asking for the 
master APM authentication key. 

Circle one:  PASS / FAIL 

 

C.3.10 Enter the Master APM Authentication key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

C.3.11 Click OK. A Success dialog box appears with the message: 

Operation completed successfully. 
Reboot system now? 

Circle one:  PASS / FAIL 
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 Operator Action Expected Result Observed Result 

C.3.12 Click Yes. The workstation reboots and the DII COE 
LOGIN screen appears. 

Circle one:  PASS / FAIL 

 

D 
4.7 Create Action 

D.1 Create A Desktop Action  

D.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Login as sysadmin. 

The desktop appears. Circle one:  PASS / FAIL 

 

D.1.2 Select Applications > Application 
Manager > DII_APPS > SysAdm. 

The Application Manager – SysAdm 
window appears. 

Circle one:  PASS / FAIL 

 

D.1.3 Double-click Create Action. The Create Action window appears. Circle one:  PASS / FAIL 

 

D.1.4 In the Action Name (Icon Label) text box, 
enter Test Action. 

Test Action appears in the Action Name 
(Icon Label) text box. 

Circle one:  PASS / FAIL 

 

D.1.5 In the Command When Action Is Opened 
(Double-clicked) text box, enter 
/usr/openwin/bin/clock 

NOTE: This method is OS specific. Use the 
relevant method on the OS being tested and note it 
in the Observed Results column. 

/usr/openwin/bin/clock appears in the 
Command When Action Is Opened 
(Double-clicked) text box. 

Circle one:  PASS / FAIL 
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 Operator Action Expected Result Observed Result 

D.1.6 Select File > Save. A Create Action – Confirmation dialog 
box appears with the message: 
The new action Test Action has 
been placed in your home folder. 

Circle one:  PASS / FAIL 

 

 

D.1.7 Click OK. The Create Action – Confirmation 
dialog box disappears. 

Circle one:  PASS / FAIL 

 

D.2 Verify the New Desktop Action  

D.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Right-click on the desktop. 
NOTE: This method is OS specific. Use the 
relevant method on the OS being tested and note it 
in the Observed Results column. 

The Workspace Menu appears. Circle one:  PASS / FAIL 

 

 

D.2.2 Select Folders > File Manager - Home. 

NOTE: This method is OS specific. Use the 
relevant method on the OS being tested and note it 
in the Observed Results column. 

A File Manager - Scripts window 
appears. 

Circle one:  PASS / FAIL 

 

 

D.2.3 Verify that an icon named Test Action is 
present in the File Manager – Scripts 
window. 

The Test Action icon is present. Circle one:  PASS / FAIL 

 

D.2.4 Double-click Test Action. A clock window appears on the screen. Circle one:  PASS / FAIL 
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 Operator Action Expected Result Observed Result 

D.3 Remove the New Desktop Action  

D.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Right-click Test Action in the File 
Manager – Scripts window. 

A drop-down menu appears. Circle one:  PASS / FAIL 

 

D.3.2 Select Put in Trash. The Test Action icon disappears. Circle one:  PASS / FAIL 

 

D.3.3 Select File > Close in the File Manager 
– Scripts window. 

The File Manager - Scripts window 
disappears. 

Circle one:  PASS / FAIL 

 

D.3.4 Select File > Exit in the Create Action 
window. 

The Create Action window disappears. Circle one:  PASS / FAIL 

 

D.3.5 Close the clock window. The clock window disappears. Circle one:  PASS / FAIL 
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 Operator Action Expected Result Observed Result 

E 
4.8 DTterm 

E.1 Setup  

E.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click DTterm in the Application 
Manager – SysAdm window. 

A Terminal window appears with a login 
prompt. 

Circle one:  PASS / FAIL 

 

 

E.1.2 At the login prompt type 
sysadmin 

A Password prompt appears. Circle one:  PASS / FAIL 

 

E.1.3 At the Password prompt type the sysadmin 
password. 

A warning message is displayed and then the 
command prompt appears. 

Circle one:  PASS / FAIL 

 

E.1.4 At the command prompt type 
id 

NOTE: This command is OS specific. Use the 
relevant command on the OS being tested and note 
it in the Observed Results column. 

The system returns 
uid=100(sysadmin) gid=1(other) 

NOTE: This result is OS specific. The result 
should indicate the user is sysadmin. 

Circle one:  PASS / FAIL 

 

 

E.1.5 At the command prompt type 
pwd 

NOTE: This command is OS specific. Use the 
relevant command on the OS being tested and note 
it in the Observed Result column. 

The system returns 
/h/USERS/local/sysadmin/Scripts  

NOTE: This result is OS specific. The result 
should indicate the above path. 

Circle one:  PASS / FAIL 
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 Operator Action Expected Result Observed Result 

E.1.6 At the command prompt type 
exit 

The Terminal window disappears. Circle one:  PASS / FAIL 

 

 

F 
4.9 Disk Manager 

F.1 Verify That the Candidate Platform Can Share (Export) A Directory  

F.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Open a Terminal window. 

A Terminal window appears with a command 
line prompt. 

Circle one:  PASS / FAIL 

 

 

F.1.2 At the command prompt type  
su - 

The Password prompt appears. Circle one:  PASS / FAIL 

 

F.1.3 At the Password prompt type the root 
password. 

The command prompt returns. Circle one:  PASS / FAIL 

 

F.1.4 At the command prompt type 
csh 

The command prompt returns. Circle one:  PASS / FAIL 

 

F.1.5 At the command prompt type 
mkdir /kpchost.home2 

The command prompt returns. Circle one:  PASS / FAIL 

 

F.1.6 At the command prompt type 
cd /home2 

The command prompt returns. Circle one:  PASS / FAIL 
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 Operator Action Expected Result Observed Result 

F.1.7 At the command prompt type 
echo > kpccp 

The command prompt returns. Circle one:  PASS / FAIL 

 

F.1.8 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

Login as sysadmin. 

The desktop appears. Circle one:  PASS / FAIL 

 

 

F.1.9 Open a Terminal window. A Terminal window appears with a command 
line prompt. 

Circle one:  PASS / FAIL 

 

F.1.10 At the command prompt type  
su - 

The Password prompt appears. Circle one:  PASS / FAIL 

 

F.1.11 At the Password prompt type the root 
password. 

The command prompt returns. Circle one:  PASS / FAIL 

 

F.1.12 At the command prompt type 
csh 

The command prompt returns. Circle one:  PASS / FAIL 

 

F.1.13 At the command prompt type 
mkdir /kpccp.home2 

The command prompt returns. Circle one:  PASS / FAIL 

 

F.1.14 At the command prompt type 
cd /home2 

The command prompt returns. Circle one:  PASS / FAIL 

 

F.1.15 At the command prompt type 
echo > kpchost 

The command prompt returns. Circle one:  PASS / FAIL 
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F.2 Share and Mount Candidate Platform�s /home2  

F.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Double-click Disk Manager in the 
Application Manager – SysAdm window. 

The Disk Manager window appears. Circle one:  PASS / FAIL 

 

F.2.2 Select the row containing /home2 in the 
Mounted On column. 

The row is highlighted. Circle one:  PASS / FAIL 

 

F.2.3 Click Export FS. The Export/Unexport File Systems 
dialog box appears. 

Circle one:  PASS / FAIL 

 

F.2.4 In the options text box enter  
rw=kpchost.kpc.disa.mil 

rw=kpchost.kpc.disa.mil appears in the 
text box. 

Circle one:  PASS / FAIL 

 

F.2.5 Click Export. A Confirmation dialog box appears asking if 
the directory should be exported permanently.  

Circle one:  PASS / FAIL 

 

F.2.6 Click Yes. The dialog boxes disappear. Circle one:  PASS / FAIL 

 

F.2.7 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

Select Applications > Application 
Manager > DII_APPS > SysAdm. 

The Application Manager – SysAdm 
window appears. 

Circle one:  PASS / FAIL 

 

 

F.2.8 Double-click Disk Manager. The Disk Manager window appears. Circle one:  PASS / FAIL 
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F.2.9 Click Mount New. The Mount File System dialog box appears. Circle one:  PASS / FAIL 

 

F.2.10 In the FILE SYSTEM text box enter 
kpccp:/home2 

kpccp:/home2 appears in the text box. Circle one:  PASS / FAIL 

 

F.2.11 In the MOUNT POINT text box enter 
/kpccp.home2 

/kpccp.home2 appears in the text box. Circle one:  PASS / FAIL 

 

F.2.12 Click MOUNT. A Confirmation dialog box appears asking if 
the directory should be mounted permanently.  

Circle one:  PASS / FAIL 

 

F.2.13 Click Yes. The dialog boxes disappear and a row for 
kpccp:/home2 appears in the Disk Manager 
window. 

Circle one:  PASS / FAIL 

 

F.2.14 At the command prompt in the Terminal 
window, type 
cd /kpccp.home2 

The command prompt returns. Circle one:  PASS / FAIL 

 

 

F.2.15 At the command prompt type 
ls 

The file kpccp appears in the listing. Circle one:  PASS / FAIL 

 

F.2.16 At the command prompt type  
cd / 

The command prompt returns. Circle one:  PASS / FAIL 
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F.2.17 In the Disk Manager window, select the row 
containing /kpccp.home2 in the Mounted On 
column. 

The row is highlighted. Circle one:  PASS / FAIL 

 

F.2.18 Click Unmount. A Confirmation dialog box appears asking if 
the directory should be unmounted permanently. 

Circle one:  PASS / FAIL 

 

F.2.19 Click Yes. The dialog box disappears and the row for 
/kpccp.home2 disappears from the Disk 
Manager window. 

Circle one:  PASS / FAIL 

 

F.2.20 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

In the Disk Manager window, select the row 
containing /home2 in the Mounted On column. 

The row is highlighted. Circle one:  PASS / FAIL 

 

 

F.2.21 Click Export FS. The Export/Unexport File Systems 
dialog box appears. 

Circle one:  PASS / FAIL 

 

F.2.22 Click Unexport. A dialog box appears asking if the directory should 
be unexported permanently. 

Circle one:  PASS / FAIL 

 

F.2.23 Click Yes. The dialog boxes disappear. Circle one:  PASS / FAIL 
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F.3 Share and Mount Validation Host�s /home2  

F.3.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

In the Disk Manager window, select the row 
containing /home2 in the Mounted On column. 

The row is highlighted. Circle one:  PASS / FAIL 

 

 

F.3.2 Click Export FS. The Export/Unexport File Systems 
dialog box appears. 

Circle one:  PASS / FAIL 

 

F.3.3 In the options text box, enter  
rw=kpccp.kpc.disa.mil 

rw=kpccp.kpc.disa.mil appears in the text 
box. 

Circle one:  PASS / FAIL 

 

F.3.4 Click Export. A Confirmation dialog box appears asking if 
the directory should be exported permanently.  

Circle one:  PASS / FAIL 

 

F.3.5 Click Yes. The dialog boxes disappear. Circle one:  PASS / FAIL 

 

F.3.6 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Click Mount New. 

The Mount File System dialog box appears. Circle one:  PASS / FAIL 

 

F.3.7 In the FILE SYSTEM text box, enter 
kpchost:/home2 

kpchost:/home2 appears in the text box. Circle one:  PASS / FAIL 

 

F.3.8 In the MOUNT POINT text box enter 
/kpchost.home2 

/kpchost.home2 appears in the text box. Circle one:  PASS / FAIL 
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F.3.9 Click MOUNT. A Confirmation dialog box appears asking if 
the directory should be mounted permanently.  

Circle one:  PASS / FAIL 

 

F.3.10 Click Yes. The dialog boxes disappear and a row for 
kpchost:/home2 appears in the Disk 
Manager window. 

Circle one:  PASS / FAIL 

 

F.3.11 At the command prompt in the  Terminal 
window, type 
cd /kpchost.home2 

The command prompt returns. Circle one:  PASS / FAIL 

 

 

F.3.12 At the command prompt type 
ls 

The file kpchost appears in the listing. Circle one:  PASS / FAIL 

 

F.3.13 At the command prompt type  
cd / 

The command prompt returns. Circle one:  PASS / FAIL 

 

F.3.14 In the Disk Manager window, select the row 
containing /kpchost.home2 in the Mounted 
On column. 

The row is highlighted. Circle one:  PASS / FAIL 

 

F.3.15 Click Unmount. A Confirmation dialog box appears asking if 
the directory should be unmounted permanently. 

Circle one:  PASS / FAIL 

 

F.3.16 Click Yes. The dialog box disappears and the row for 
/kpchost.home2 disappears from the Disk 
Manager window. 

Circle one:  PASS / FAIL 
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F.3.17 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

In the Disk Manager window, select the row 
containing /home2 in the Mounted On column. 

The row is highlighted. Circle one:  PASS / FAIL 

 

 

F.3.18 Click Export FS. The Export/Unexport File Systems 
dialog box appears. 

Circle one:  PASS / FAIL 

 

F.3.19 Click Unexport. A dialog box appears asking if the directory should 
be unexported permanently. 

Circle one:  PASS / FAIL 

 

F.3.20 Click Yes. The dialog boxes disappear. Circle one:  PASS / FAIL 

 

F.3.21 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 
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  F.4 
4.10 Format and mount disk partition  

 

 Warning - executing the following tests in the greyed area may corrupt the disk table of the disk under 
test. 

 

F.4.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

In the Disk Manager window, highlight the row 
with /test. 

The row with /test is highlighted. Circle one:  PASS / FAIL 

 

 

F.4.2 Click Unmount. A Confirmation dialog box appears asking if 
the directory should be unmounted permanently. 

Circle one:  PASS / FAIL 

 

F.4.3 Click Yes. The dialog box disappears and the row for /test 
disappears from the Disk Manager window. 

Circle one:  PASS / FAIL 

 

F.4.4 In the Disk Manager window, click New FS. 

 

The New File System dialog box appears. Circle one:  PASS / FAIL 

 

F.4.5 In the DISK DEVICE text box, enter 

i.e. /dev/dsk/c0t0d0s7 

NOTE: This step is platform specific. Enter the 
device name for the test partition created during 
Validation Cell setup here and in the following 
steps. 

i.e. /dev/dsk/c0t0d0s7 is displayed. Circle one:  PASS / FAIL 
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F.4.6 Click OK. A Please wait message box is displayed while 
the partition is formatted.  The message box 
disappears and the Disk Manager window 
reappears. 

NOTE: The message box may disappear quickly. 

Circle one:  PASS / FAIL 

 

F.4.7 Click Mount New. The Mount File System dialog box is 
displayed. 

Circle one:  PASS / FAIL 

F.4.8 In the FILE SYSTEM text box enter  

 i.e.      /dev/dsk/c0t0d0s7 

i.e. /dev/dsk/c0t0d0s7 appears in the 
textbox 

Circle one:  PASS / FAIL 

F.4.9 In the MOUNT POINT text box enter 
/home3 

/home3 appears in the text box. Circle one:  PASS / FAIL 

 

F.4.10 Click MOUNT. The dialog box appears with the following 
message: 
Mount the File System Permanently?  

Circle one:  PASS / FAIL 

 

F.4.11 Click Yes. i.e. /dev/dsk/c0t0d0s7 shows /home3 in 
Mounted On column.   

 Circle one:  PASS / FAIL 

F.4.12 Highlight the row with /home3 in the Mounted 
On column. 

The row with /home3 is highlighted. Circle one:  PASS / FAIL 

F.4.13 Click Unmount. A Confirmation dialog box appears asking if 
the directory should be unmounted permanently. 

 Circle one:  PASS / FAIL 

F.4.14 Click Yes. The dialog box disappears and the row for /home3 
disappears from the Disk Manager window. 

 Circle one:  PASS / FAIL 
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F.4.15 Click Exit in the Disk Manager window. The Disk Manager window disappears. Circle one:  PASS / FAIL 

 

G 
4.11 Edit Local Hosts 

G.1 Add A New Host  

G.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click Edit Local Hosts in the 
Application Manager – SysAdm window. 

The Edit Hosts window appears. Circle one:  PASS / FAIL 

 

 

G.1.2 Click Add. The Add Machine window appears. Circle one:  PASS / FAIL 

 

G.1.3 In the MACHINE NAME text box, enter 
newmachine 

newmachine appears in the MACHINE NAME 
text box. 

Circle one:  PASS / FAIL 

 

 

G.1.4 In the MACHINE ADDRESS text box enter 
169.254.0.100 

169.254.0.100 appears in the MACHINE 
ADDRESS text box. 

Circle one:  PASS / FAIL 

 

G.1.5 Click OK. The Add Machine window disappears and 
newmachine shows up in the Edit Hosts 
window. 

Circle one:  PASS / FAIL 
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G.1.6 At the command prompt in the Terminal 
window type 
cat /etc/hosts 

The contents of the /hosts file are displayed. Circle one:  PASS / FAIL 

 

 

G.1.7 Verify that an entry exists for  
169.254.0.100 newmachine 

The line exists. Circle one:  PASS / FAIL 

 

G.2 Delete A Host  

G.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Select newmachine in the Edit Hosts 
window. 

The line containing newmachine is highlighted. Circle one:  PASS / FAIL 

G.2.2 Click Delete. A Confirmation Required dialog box 
appears with the following message 
Are you sure you want to remove 
host 169.254.0.100? 

Circle one:  PASS / FAIL 

G.2.3 Click Yes. The Confirmation Required dialog box 
disappears and newmachine is removed from the 
Edit Hosts window. 

Circle one:  PASS / FAIL 

G.2.4 At the command prompt in the Terminal 
window type 
cat /etc/hosts 

The contents of the hosts file are displayed. Circle one:  PASS / FAIL 
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G.2.5 Verify that the entry for  
169.254.0.100 newmachine  

has been removed. 

The line does not exist. Circle one:  PASS / FAIL 

G.2.6 Click Close in the Edit Hosts window. The Edit Hosts window disappears. Circle one:  PASS / FAIL 

 

H 
4.12 Network Installation Server and Segment Installer 

H.1 Load Segment To Candidate Platform  

H.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Insert the OnlineDocs (ONDOC) v 4.2.0.0 
tape into the tape drive or, if using the KPC Test 
Data CD, insert the CD into the cdrom drive. 

The tape/CD is inserted. Circle one:  PASS / FAIL 

H.1.2 Double-click Network Installation 
Server in the Application Manager – 
SysAdm window. 

The Segment Installation Server 
window appears. 

Circle one:  PASS / FAIL 
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H.1.3 If a tape is used, click Read Contents, 

 or, 

if the KPC Test Data CD is used, proceed as 
follows: 

Click Select Source, 

Click CD-ROM, 

Double-click “seg” in the Directories 
column, 

Double-click ONDOC.tar in the Files 
column, 

Click Read Contents. 

The Segment Installation Server 
window disappears while message boxes appear 
informing that the system is Checking media 
and that Read Content is in progress. 

The Segment Installation Server 
window reappears with OnlineDocs listed under 
Select Software To Load. 

Circle one:  PASS / FAIL 

H.1.4 Select OnlineDocs. OnlineDocs is highlighted. Circle one:  PASS / FAIL 

 

H.1.5 Click Release Notes. A RELEASE NOTES window opens with Release 
Notes text. 

Circle one:  PASS / FAIL 

 

H.1.6 Click OK. The RELEASE NOTES window disappears. Circle one:  PASS / FAIL 

 

H.1.7 Click Requires. A REQUIRES SEGMENTS window opens listing 
segments required before installing OnlineDocs. 

Circle one:  PASS / FAIL 

 

H.1.8 Click OK. The REQUIRES SEGMENTS window disappears. Circle one:  PASS / FAIL 
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H.1.9 Click Conflicts. An INFORMATIONAL MESSAGE dialog box 
opens informing that the Conflicts descriptor is 
not available. 

Circle one:  PASS / FAIL 

 

H.1.10 Click OK. The dialog box disappears. Circle one:  PASS / FAIL 

 

H.1.11 In the Available Disks panel select the row 
containing /home2. 

The row is highlighted. Circle one:  PASS / FAIL 

 

H.1.12 Click Load. An ENTER A PASSWORD dialog box appears.  Circle one:  PASS / FAIL 

 

H.1.13 Enter the APM Authentication key in the text box. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

H.1.14 Click OK. Control returns to the Segment 
Installation Server window. 

OnlineDocs[ALL] appears in the list under 
Segments Currently Loaded On This 
Network Server. 

Circle one:  PASS / FAIL 

H.1.15 Select Installed > View Installation 
Log. 

An Install Log window appears indicating 
OnlineDocs was successfully loaded on the 
kpccp Network Server. 

Circle one:  PASS / FAIL 

 

 

H.1.16 Click OK. The Install Log window disappears. Circle one:  PASS / FAIL 
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H.2 Install the Loaded Segment On the Candidate Platform  

H.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click Segment Installer in the 
Application Manager – SysAdm window. 

The  Installer window appears. Circle one:  PASS / FAIL 

H.2.2 Click Select Source. The Select Source dialog box appears. Circle one:  PASS / FAIL 

 

H.2.3 Select LOCAL in the Host panel and NETWORK in 
the Device panel. 

The LOCAL and NETWORK radio buttons are 
highlighted. 

Circle one:  PASS / FAIL 

 

H.2.4 Click OK. The Select Source dialog box disappears. Circle one:  PASS / FAIL 

 

H.2.5 Click Read Contents. The Installer window shows OnlineDocs 
listed under Select Software To Install. 

Circle one:  PASS / FAIL 

 

H.2.6 Select OnlineDocs. OnlineDocs is highlighted. Circle one:  PASS / FAIL 

 

H.2.7 Click Install. An ENTER A PASSWORD dialog box appears. Circle one:  PASS / FAIL 

 

H.2.8 Enter the APM Authentication key in the text box. Asterisks appear in the text box. Circle one:  PASS / FAIL 
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H.2.9 Click OK. The dialog box disappears.  

The Installer window shows OnlineDocs 
listed under Currently Installed 
Segments. 

Circle one:  PASS / FAIL 

H.3 Verify Installation  

H.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Select Installed > View Installation 
Log. 

An Install Log window appears indicating 
OnlineDocs was successfully installed. 

Circle one:  PASS / FAIL 

H.3.2 Click OK. The Install Log window disappears. Circle one:  PASS / FAIL 

 

H.4 Test Segment De-installation  

H.4.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

In the list under Currently Installed 
Segments, select OnlineDocs. 

OnlineDocs is highlighted. Circle one:  PASS / FAIL 

H.4.2 Click Deinstall Software. A RESPOND TO THE QUESTION dialog box 
appears to verify that you really want to remove the 
segment. 

Circle one:  PASS / FAIL 
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H.4.3 Click No. The Installer window reappears with 
OnlineDocs still listed in the Currently 
Installed Segments panel. 

Circle one:  PASS / FAIL 

 

H.4.4 Click Deinstall Software. A RESPOND TO THE QUESTION dialog box 
appears to verify that you really want to remove the 
segment. 

Circle one:  PASS / FAIL 

 

H.4.5 Click Yes. 

 

The Installer window appears. Circle one:  PASS / FAIL 

H.4.6 Click Exit. The Installer window disappears. Circle one:  PASS / FAIL 

 

H.4.7 In the Network Installation Server 
window select OnlineDocs[ALL] under 
Segments Currently Loaded On This 
Network Server. 

OnlineDocs[ALL] is highlighted. Circle one:  PASS / FAIL 

H.4.8 Click Deinstall Software. 

 

A RESPOND TO THE QUESTION dialog box 
appears to verify that you really want to remove the 
segment. 

Circle one:  PASS / FAIL 

H.4.9 Enter the Master APM Authentication Key Asterisks appear in the text box. Circle one: PASS / FAIL 

H.4.10 Click OK. The text box closes. Circle one:  PASS / FAIL 

H.4.11 Click Exit. The Segment Installation Server 
window disappears. 

Circle one:  PASS / FAIL 

 

H.4.12 Eject the tape or CD. The tape or CD ejects. Circle one:  PASS / FAIL 
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I 
4.13 Set Routes 

I.1 Setup  

I.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

At the command prompt in the Terminal 
window, type 
netstat -nr 

Network routing information is displayed. Circle one:  PASS / FAIL 

I.1.2 Verify that there is not a line containing default. There is no default listed. Circle one:  PASS / FAIL 

 

I.1.3 Double-click Set Routes in the 
Application Manager – SysAdm window. 

The Default Router Setup window 
appears. 

Circle one:  PASS / FAIL 

 

I.1.4 In the Default Router IP Address text box, 
enter 
204.34.175.194 

204.34.175.194 appears in the text box. Circle one:  PASS / FAIL 

 

I.1.5 Click OK. A Done dialog box appears informing that the 
operation completed successfully.   

Circle one:  PASS / FAIL 

 

I.1.6 Click OK. The dialog box and the Default Router 
Setup window disappear. 

Circle one:  PASS / FAIL 

 

I.1.7 At the command prompt type 
netstat -nr 

Network routing information is displayed. Circle one:  PASS / FAIL 

 



© 2003, The Open Group 
Chapter 1, Page 41 

 
 

 

 

 Operator Action Expected Result Observed Result 

I.1.8 Verify that a line containing default is listed. default is listed with the IP address 
204.34.175.194. 

Circle one:  PASS / FAIL 

 

J 
4.14 Set System Time 

J.1 Setup  

J.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Right-click on the desktop. 

NOTE: This method is OS specific. Use the 
relevant method on the OS being tested and note it 
in the Observed Results column. 

The Workspace Menu appears. Circle one:  PASS / FAIL 

J.1.2 Select Applications > OW Clock. 

NOTE: This method is OS specific. Use the 
relevant method on the OS being tested and note it 
in the Observed Results column. 

A Clock window appears displaying the current 
local time in the current time zone. 

Circle one:  PASS / FAIL 

J.1.3 Close the clock window. The clock window disappears. Circle one:  PASS / FAIL 
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J.1.4 Double-click Set System Time in the 
Application Manager – SysAdm window. 

 

NOTE: The System Time window displays the 
local time as if the system time is GMT. Thus, the 
hour representation will be shifted by the GMT 
offset from the current local time. In the steps 
below, time entered into the System Time 
window will be interpreted, as GMT while the OW 
Clock display will be system time. 

 

NOTE: The steps below may cause the screen lock 
to engage. If so, enter the sysadmin password 
and continue. 

A System Time window appears with a date 
time group (DTG) in the form ddhhmmZ MON 
YYYY, where: 

dd represents the day of the month. 

hh represents the hour (in GMT). 

mm represents the minute. 

Z is a constant (for Zulu time). 

MON represents the three-letter month abbreviation. 

YYYY represents the four-digit year. 

The time displayed should be the same as the clock 
display shifted by the GMT offset. 

Circle one:  PASS / FAIL 

J.1.5 In the Enter DTG text box change the third and 
fourth digits (hour) to a different value. 

The value appears in the text box. Circle one:  PASS / FAIL 

 

J.1.6 Click OK. A Done dialog box appears indicating that the 
operation has completed successfully.  

Circle one:  PASS / FAIL 

 

J.1.7 Click OK. The dialog box and the System Time window 
disappear. 

Circle one:  PASS / FAIL 

 

J.1.8 Open the clock window and verify that the 
clock window displays the new time. 

The clock window displays the new time. Circle one:  PASS / FAIL 
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J.1.9 Close the clock window. The clock window disappears. Circle one:  PASS / FAIL 

 

J.1.10 Double-click Set System Time. A System Time window appears. Circle one:  PASS / FAIL 

 

J.1.11 Enter the current local time in the Enter DTG 
text box. 

The value appears in the text box. Circle one:  PASS / FAIL 

 

J.1.12 Click OK. A Done dialog box appears indicating that the 
operation has completed successfully. 

Circle one:  PASS / FAIL 

 

J.1.13 Click OK. The dialog box and the System Time window 
disappear.  

Circle one:  PASS / FAIL 

 

J.1.14 Open the clock window and verify that the 
clock window displays the current time. 

The clock window displays the current time. Circle one:  PASS / FAIL 

 

J.1.15 Close the clock window. The clock window disappears. Circle one:  PASS / FAIL 
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K 
4.15 Text Editor 

K.1 Use the Text Editor To Create A Test File  

K.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click Text Edit in the Application 
Manager – SysAdm window. 

A Text Editor – (UNTITLED) window 
appears. 

Circle one:  PASS / FAIL 

K.1.2 In the text window, enter the following text: 

This text is test text. 

This text appears in the text window. Circle one:  PASS / FAIL 

 

K.1.3 Select File > Save,(Needed). A Text Editor - Save As dialog box 
appears. 

Circle one:  PASS / FAIL 

 

K.1.4 Enter TestText in the Enter file name text 
box. 

TestText appears in the Enter file name 
text box. 

Circle one:  PASS / FAIL 

 

K.1.5 Click OK. The Text Editor - Save As dialog box 
closes. 

Circle one:  PASS / FAIL 
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K.2 Verify Existence Of Test File  

K.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Right-click on the desktop. 

NOTE: This method is OS specific. Use the 
relevant method on the OS being tested and note it 
in the Observed Results column. 

The Workspace Menu appears. Circle one:  PASS / FAIL 

K.2.2 Select Folders > File Manager – Home.  

NOTE: This method is OS specific. Use the 
relevant method on the OS being tested and note it 
in the Observed Results column. 

A File Manager - Scripts window 
appears. 

Circle one:  PASS / FAIL 

K.2.3 Verify that an icon named TestText is present in 
the File Manager – Scripts window. 

The TestText icon is present. Circle one:  PASS / FAIL 

 

K.2.4 Double-click TestText. A Text Editor – Test Text window 
appears displaying the text: 

This text is test text. 

Circle one:  PASS / FAIL 
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K.3 Delete the Test File  

K.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

In the File Manager - Scripts window, 
right-click TestText and select Put in 
Trash. 

NOTE: This method is OS specific. Use the 
relevant method on the OS being tested and note it 
in the Observed Results column. 

The Test Text icon disappears. Circle one:  PASS / FAIL 

K.3.2 Close the File Manager - Scripts, and 
both Text Editor - TestText windows. 

The File Manager - Scripts, and both 
Text Editor - TestText windows 
disappear. 

Circle one:  PASS / FAIL 

 

L 
4.16 XTerm 

L.1 Setup  

L.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click XTerm in the Application 
Manager – SysAdm window. 

A login window appears. Circle one:  PASS / FAIL 

L.1.2 At the login prompt type 
sysadmin 

A Password prompt appears. Circle one:  PASS / FAIL 
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L.1.3 At the Password prompt type the sysadmin 
password. 

The DoD Security Banner is displayed and then the 
command prompt appears. 

Circle one:  PASS / FAIL 

 

L.1.4 At the command prompt type 
id 

NOTE: This command is OS specific. Use the 
relevant command on the OS being tested and note 
it in the Observed Results column. 

The system returns 
uid=100(sysadmin) gid=1(other) 

NOTE: This result is OS specific. The result 
should indicate the user is sysadmin. 

Circle one:  PASS / FAIL 

L.1.5 At the command prompt type 
pwd  

NOTE: This command is OS specific. Use the 
relevant command on the OS being tested and note 
it in the Observed Results column. 

The system returns 
/h/USERS/local/sysadmin/Scripts  

NOTE: This result is OS specific. The result 
should indicate the above path. 

Circle one:  PASS / FAIL 

L.1.6 At the command prompt type 
exit 

The login window disappears. Circle one:  PASS / FAIL 
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M 
4.17 Reboot System 

M.1 Verify System Can Be Rebooted  

M.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click Reboot System in the 
Application Manager – SysAdm window. 

A Reboot dialog box appears with the question: 
Reboot machine? 

Circle one:  PASS / FAIL 

M.1.2 Click No. The dialog box disappears. Circle one:  PASS / FAIL 

 

M.1.3 Double-click Reboot System in the 
Application Manager – SysAdm window. 

A Reboot dialog box appears with the question: 
Reboot machine? 

Circle one:  PASS / FAIL 

 

M.1.4 Click Yes. The workstation reboots and the DII COE 
LOGIN screen appears. 

Circle one:  PASS / FAIL 
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N 
4.18 Shutdown System 

N.1 Verify the System Shuts Down  

N.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Log in as sysadmin. 

The desktop appears. Circle one:  PASS / FAIL 

N.1.2 Select Applications > Application 
Manager > DII_APPS > SysAdm. 

The Application Manager – SysAdm 
window appears. 

Circle one:  PASS / FAIL 

 

N.1.3 Double-click Shutdown System. A Shut down dialog box appears. Circle one:  PASS / FAIL 

 

N.1.4 Click No. The Shut down dialog box disappears. Circle one:  PASS / FAIL 

 

N.1.5 Double-click Shutdown System in the 
Application Manager – SysAdmin 
window. 

A Shut down dialog box appears. Circle one:  PASS / FAIL 

 

N.1.6 Click Yes. The system shuts down and a boot prompt is 
presented. 

Circle one:  PASS / FAIL 

 

N.1.7 At the prompt enter the proper command for 
system boot. 
 

The system boots and the DII COE LOGIN 
screen appears with the DoD security warning 
message and the Please enter your user 
name text box. 

Circle one:  PASS / FAIL 
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O 
4.19 Verify secman    Login, Profile Selector, Change Password Tool, Command Line Accessibility, and Icon 

Accessibility 

O.1 Verify secman Login  

O.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Verify that the DII COE LOGIN screen appears. 

The DII COE LOGIN screen appears with the 
DoD security warning message and the Please 
enter your user name text box. 

Circle one:  PASS / FAIL 

 

O.1.2 Log in as the Security Administrator by typing 
secman in the Please enter your user 
name prompt and pressing ENTER. 

The password screen appears with the Please 
enter your password text box. 

Circle one:  PASS / FAIL 

 

O.1.3 Type the password for the secman account in the 
Please enter your password text box and 
press ENTER.  

A dialog box appears indicating that the password 
needs to be changed. 

Circle one:  PASS / FAIL 

 

O.1.4 Click OK. A command line window appears with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 

 

 

O.1.5 Enter the initial password. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 
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O.1.6 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password: _____________ 

 

O.1.7 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 

 

O.1.8 Log in as user secman with the new password. An INFORMATIONAL MESSAGE dialog box 
appears confirming COE login processing is 
complete. 
 

Circle one:  PASS / FAIL 

 

 

O.1.9 Click OK in the INFORMATIONAL MESSAGE 
dialog box. 

The dialog box disappears. Circle one:  PASS / FAIL 

 

O.2 Verify secman Profile Selector Functionality  

O.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Click Profile Selector (the head with a 
question mark). 

The Profile Selector window appears with 
SSO Default listed in the Selected 
Profiles panel. 

Circle one:  PASS / FAIL 

O.2.2 Click Cancel. The Profile Selector window disappears. Circle one:  PASS / FAIL 
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O.3 Verify secman Change Password Tool Functionality  

O.3.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Access the Change Password Tool from the 
CDE Panel by selecting the arrow above the 
Profile Selector icon.  

The DII Tools menu appears. Circle one:  PASS / FAIL 

 

O.3.2 Select the Change Password Tool menu 
item.  

The Change your password window 
appears. 

Circle one:  PASS / FAIL 

 

O.3.3 Click Cancel. The Change your password window 
disappears. 

Circle one:  PASS / FAIL 

 

O.4 Verify Command Line Access  

O.4.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Open a Terminal window. 

A Terminal window appears with a command 
line prompt. 

Circle one:  PASS / FAIL 

 

O.4.2 At the command prompt type 
id 

NOTE: This command is OS specific. Use the 
relevant command on the OS being tested and note 
it in the Observed Results column. 

The system returns 
uid=101(secman) gid=36(admin) 

NOTE: This result is OS specific. The result 
should indicate the user is secman. 

Circle one:  PASS / FAIL 
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O.4.3 At the command prompt type 
pwd  

NOTE: This command is OS specific. Use the 
relevant command on the OS being tested and note 
it in the Observed Results column. 

The system returns 
/h/USERS/local/secman/Scripts  

NOTE: This result is OS specific. The result 
should indicate the above path. 

Circle one:  PASS / FAIL 

 

O.4.4 At the command prompt type 
exit 

The Terminal window disappears. Circle one:  PASS / FAIL 

 

O.5 Verify Icon Access  

O.5.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Right-click on the desktop. 

NOTE: This method is OS specific. Use the 
relevant method on the OS being tested and note it 
in the Observed Results column. 

The Workspace Menu appears. Circle one:  PASS / FAIL 

 

O.5.2 Select Applications > Application 
Manager 

NOTE: This method is OS specific. Use the 
relevant method on the OS being tested and note it 
in the Observed Results column. 

The Application Manager window appears. Circle one:  PASS / FAIL 

 

O.5.3 Double-click DII_APPS. The Application Manager – DII_APPS 
window appears. 

Circle one:  PASS / FAIL 
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O.5.4 Double-click SecAdm. The Application Manager – SecAdm 
window appears with the following icons: ..(go 
up), APM Client, APM Key Server, 
APM Server Reload, APM Server 
Start, APM Server Stop, Assign 
Passwords, Audit Log File Manager, 
Edit APM Configuration, Merge 
Host, Profile Selector Config, 
Remove Host. 

Circle one:  PASS / FAIL 

 

P 
4.20 APM Client 

P.1 Create A New Account, Profile, and Group On the Candidate Platform  

P.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click APM Client. 

An Input dialog box appears asking for the APM 
master authentication key. 

Circle one:  PASS / FAIL 

 

P.1.2 Enter the APM master authentication key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

P.1.3 Click OK. The Account and Profile Manager 
dialog box appears. 

Circle one:  PASS / FAIL 

 

P.1.4 Select File > New Account. A Create Account window appears. Circle one:  PASS / FAIL 
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P.1.5 Enter the following values: 

Login: AcctCon 

Password: temp 

Password Confirm: temp 

Template: secman  

Home server: EACH HOST 

Manage as: Local 

Each item is filled in. Circle one:  PASS / FAIL 

 

P.1.6 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 

 

P.1.7 Verify kpccp appears in the Assigned Hosts 
panel. 

Note:  If kpccp does not appear in the 
Assigned Hosts panel, double-click kpccp in 
the Available Hosts panel, which moves it to 
the Assigned Hosts panel. 

kpccp appears in the Assigned Hosts panel. Circle one:  PASS / FAIL 

 

P.1.8 Click Submit. A Status Summary dialog box appears 
indicating the new user has been added. 

Circle one:  PASS / FAIL 

 

P.1.9 Click OK. The Status Summary dialog box disappears. Circle one:  PASS / FAIL 

 

P.1.10 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 
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P.1.11 Select File > New Profile. A Create Profile window appears. Circle one:  PASS / FAIL 

 

P.1.12 In the Profile Name text box, enter  

ProCon. 

ProCon appears in the text box. Circle one:  PASS / FAIL 

 

P.1.13 Select SSO Default from the Profile 
Template drop-down list. 

SSO Default is selected. Circle one:  PASS / FAIL 

 

P.1.14 Click Features. The Features tab is displayed. Circle one:  PASS / FAIL 

 

P.1.15 Select Sol Security Administration 
4.2.0.5 from the Segments box. 

Sol Security Administration 
4.2.0.5 is highlighted. 

Circle one:  PASS / FAIL 

 

P.1.16 In the Features box, deselect the following 
items 
Security Administration-APM Client 

Security Administration-APM Server 
Start 

Security Administration-Assign 
Passwords. 

These items are no longer checked. Circle one:  PASS / FAIL 

 

P.1.17 Click Submit. A Status Summary dialog box appears 
indicating the new profile has been added. 

Circle one:  PASS / FAIL 

 

P.1.18 Click OK. The Status Summary dialog box disappears. Circle one:  PASS / FAIL 
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P.1.19 Click Groups. The Groups tab is displayed. Circle one:  PASS / FAIL 

 

P.1.20 Select File > New Group. A Create Group window appears. Circle one:  PASS / FAIL 

 

P.1.21 In the Group name text box, enter  

GrpCon. 

GrpCon appears in the text box. Circle one:  PASS / FAIL 

 

P.1.22 Select admin from the Template drop-down 
list. 

admin is selected. Circle one:  PASS / FAIL 

 

P.1.23 Click Accounts. The Accounts tab is displayed. Circle one:  PASS / FAIL 

 

P.1.24 Double-click SSO in the Assigned Accounts 
panel. 

SSO moves to the Available Accounts 
panel. 

Circle one:  PASS / FAIL 

 

P.1.25 Click Hosts. The Hosts tab is displayed. Circle one:  PASS / FAIL 

 

P.1.26 Verify kpccp appears in the Assigned Hosts 
panel. 

kpccp appears in the Assigned Hosts panel. Circle one:  PASS / FAIL 

 

P.1.27 Click Submit. A Status Summary dialog box appears 
indicating the new group has been added. 

Circle one:  PASS / FAIL 

 

P.1.28 Click OK. The Status Summary dialog box disappears. Circle one:  PASS / FAIL 
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P.1.29 Click File > Exit. An Exit confirmation dialog box appears. Circle one:  PASS / FAIL 

 

P.1.30 Click Yes. The Account and Profile Manager 
dialog box disappears. 

Circle one:  PASS / FAIL 

 

P.2 Create A New Account, Profile, and Group On the Validation Host  

P.2.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

 

Login as secman. 

The desktop appears. Setup 

 

P.2.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 

 

P.2.3 Double-click APM Client. An Input dialog box appears asking for the 
master APM authentication key. 

Setup 

 

P.2.4 Enter the master APM authentication key. Asterisks appear in the text box. Setup 

 

P.2.5 Click OK. The Account and Profile Manager 
dialog box appears. 

Setup 

 

P.2.6 Select File > New Account. A Create Account window appears. Setup 
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P.2.7 Enter the following values: 

Login: AcctCon 

Password: temp 

Password Confirm: temp 

Template: sysadmin  

Home server: EACH HOST 

Manage as: Local 

Each item is filled in. Setup 

 

P.2.8 Click Submit. A Status Summary dialog box appears 
indicating the new user has been added. 

Setup  

 

P.2.9 Click OK. The Status Summary dialog box disappears. Setup 

 

P.2.10 Click Profiles. The Profiles tab is displayed. Setup 

 

P.2.11 Select File > New Profile. A Create Profile window appears. Setup 

 

P.2.12 In the Profile Name text box, enter  

ProCon. 

ProCon appears in the text box. Setup 

 

P.2.13 Select SA Default from the Profile 
Template drop-down list. 

SA Default is selected. Setup 
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P.2.14 Click Features. The Features tab is displayed. Setup 

 

P.2.15 Select Sol System Administration 
4.2.0.5 from the Segments box. 

Sol System Administration 4.2.0.5 is 
highlighted. 

Setup 

 

P.2.16 In the Features box, deselect the following 
items: 
System Administration-Change 
Machine ID 

System Administration-Disk Manager 

System Administration-Edit Local 
Hosts. 

These items are no longer checked. Setup 

 

P.2.17 Click Submit. A Status Summary dialog box appears 
indicating the new profile has been added. 

Setup  

 

P.2.18 Click OK. The Status Summary dialog box disappears. Setup  

 

P.2.19 Click Groups. The Groups tab is displayed. Setup  

 

P.2.20 Select File > New Group. A Create Group window appears. Setup 

  

P.2.21 In the Group Name text box, enter  

GrpCon. 

GrpCon appears in the text box. Setup  
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P.2.22 Select other from the Template drop-down 
list. 

other is selected. Setup  

 

P.2.23 Click Accounts. The Accounts tab is displayed. Setup  

 

P.2.24 Double-click daemon, root and SA in the 
Assigned Accounts panel. 

daemon, root and SA move to the 
Available Accounts panel. 

Setup  

 

P.2.25 Click Hosts. The Hosts tab is displayed. Setup  

 

P.2.26 Verify kpchost appears in the Assigned 
Hosts panel. 

kpchost appears in the Assigned Hosts 
panel. 

Setup  

 

P.2.27 Click Submit. A Status Summary dialog box appears 
indicating the new group has been added. 

Setup  

 

P.2.28 Click OK. The Status Summary dialog box disappears. Setup  

 

P.2.29 Click File > Exit. An Exit Confirmation dialog box appears. Setup  

 

 

P.2.30 Click Yes. The Account and Profile Manager 
dialog box disappears. 

Setup  
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Q 
4.21 APM Server Reload 

Q.1 Setup  

Q.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click APM Server Reload. 

An INFORMATIONAL MESSAGE box appears: 
APM Server reloaded successfully. 

Circle one:  PASS / FAIL 

 

Q.1.2 Click OK. The INFORMATIONAL MESSAGE box 
disappears. 

Circle one:  PASS / FAIL 

 

R 
4.22 APM Server Stop 

R.1 Setup  

R.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click APM Server Stop. 

An INFORMATIONAL MESSAGE box appears: 
APM Server successfully stopped. 

Circle one:  PASS / FAIL 

 

R.1.2 Click OK. The INFORMATIONAL MESSAGE box 
disappears. 

Circle one:  PASS / FAIL 

 

R.1.3 Double-click APM Server Stop. An INFORMATIONAL MESSAGE box appears: 
APM Server already stopped. 

Circle one:  PASS / FAIL 

 

R.1.4 Click OK. The INFORMATIONAL MESSAGE box 
disappears. 

Circle one:  PASS / FAIL 
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S 
4.23 APM Server Start 

S.1 Setup  

S.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click APM Server Start. 

An INFORMATIONAL MESSAGE box appears: 
APM Server started successfully. 

Circle one:  PASS / FAIL 

 

S.1.2 Click OK. The INFORMATIONAL MESSAGE box 
disappears. 

Circle one:  PASS / FAIL 

 

S.1.3 Double-click APM Server Start. An INFORMATIONAL MESSAGE box appears: 
APM Server is already running! 

Circle one:  PASS / FAIL 

 

S.1.4 Click OK. The INFORMATIONAL MESSAGE box 
disappears.  

Circle one:  PASS / FAIL 

 

T 
4.24 Assign Passwords 

T.1 Setup  

T.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click Assign passwords. 

The Assign passwords dialog box appears. Circle one:  PASS / FAIL 

 

T.1.2 Click Cancel. The Assign passwords dialog box 
disappears. 

Circle one:  PASS / FAIL 
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U 
4.25 Audit Log File Manager 

U.1 Setup  

U.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click Audit Log File Manager. 

The Audit Log File Manager dialog box 
appears. 

Circle one:  PASS / FAIL 

U.1.2 Click Cancel. The Audit Log File Manager dialog box 
disappears. 

Circle one:  PASS / FAIL 

 

V 
4.26 Edit APM Configuration 

V.1 Setup  

V.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click Edit APM Configuration. 

The Edit APM Configuration window 
appears. 

Circle one:  PASS / FAIL 

 

V.1.2 In the Master Host text box, enter 
kpchost 

kpchost appears in the text box. Circle one:  PASS / FAIL 

 

V.1.3 Click Submit. A Done dialog box appears indicating: 
Operation completed successfully. 

Circle one:  PASS / FAIL 

 

V.1.4 Click OK. The dialog box and the Edit APM 
Configuration window disappear. 

Circle one:  PASS / FAIL 
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V.1.5 Select EXIT button from CDE. 

 

A Logout Confirmation window appears. Circle one:  PASS / FAIL 

V.1.6 Select OK. System exits and the DII COE LOGIN screen 
appears. 

Circle one:  PASS / FAIL 

 

W 
4.27 Set Local Authentication Key 

W.1 Set Key on Candidate Platform  

W.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Login as keyman. 

A dialog box appears indicating that the password 
needs to be changed. 

 

Setup 

 

W.1.2 Click OK. A command line window appears with an Enter 
login password prompt. 

Circle one:  PASS / FAIL 

 

W.1.3 Enter the initial password. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Circle one:  PASS / FAIL 

 

W.1.4 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Circle one:  PASS / FAIL 

 

Password: _____________ 

W.1.5 Re-enter the new password. The DII COE LOGIN screen appears. Circle one:  PASS / FAIL 

 



© 2003, The Open Group 
Chapter 1, Page 66 

 
 

 

 

 Operator Action Expected Result Observed Result 

W.1.6 Log in as user keyman with the new password. The desktop appears.  
 

Circle one:  PASS / FAIL 

 

W.1.7 Select Applications > Application 
Manager > DII_APPS > APM > 
Authentication Manager. 

The Authentication Manager window 
appears. 

Circle one:  PASS / FAIL 

 

W.1.8 Enter the Local APM authentication key. 

 

Asterisks appear in the textbox. Circle one:  PASS / FAIL 

 

W.1.9 Click Set Key. 

 

A Message dialog box appears stating that the 
local key is set. 

Circle one:  PASS / FAIL 

 

W.1.10 Click OK. 

 

The dialog box disappears. Circle one:  PASS / FAIL 

 

W.1.11 Click Close. The Authentication Manager window 
appears. 

Circle one:  PASS / FAIL 

 

W.1.12 Select EXIT button from CDE. 

 

A Logout Confirmation window appears. Circle one:  PASS / FAIL 

W.1.13 Select OK. System exits and the DII COE LOGIN screen 
appears. 

Circle one:  PASS / FAIL 
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W.2 Set Key on Validation Host  

W.2.1 NOTE: Perform the following steps on the 
Validation Host (kpchost). 

 

Login as keyman. 

A dialog box appears indicating that the password 
needs to be changed. 

 

Setup 

 

W.2.2 Click OK. A command line window appears with an Enter 
login password prompt. 

Setup  

W.2.3 Enter the initial password. 

NOTE: The mouse cursor must be within the 
command line window. 

The prompt changes to New password. Setup  

W.2.4 Enter a new password. 

 

Record the new password. 

The prompt changed to Re-enter new 
password. 

Setup 

 

Password: _____________ 

W.2.5 Re-enter the new password. The DII COE LOGIN screen appears. 

 

Setup  

W.2.6 Log in as user keyman with the new password. The desktop appears.  
 

Setup  

W.2.7 Select Applications > Application 
Manager > DII_APPS > APM > 
Authentication Manager. 

The Authentication Manager window 
appears. 

Setup  

W.2.8 Enter the Master APM authentication key. 

 

Asterisks appear in the textbox. Setup  
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W.2.9 Click Set Client’s Local Key. 

 

The Hosts List window appears. Setup  

W.2.10 In the Additional Host text box type 
kpccp. 

 

kpccp appears in the text box. Setup  

W.2.11 Click Add Host. The Set Key For New Host dialog box 
appears. 

Setup 

W.2.12 In the New auth key and Re-enter auth 
key text boxes type the local authentication key for 
kpccp. 

Asterisks appear in the textboxes. Setup 

W.2.13 Click Submit. 

 

A Message dialog box appears stating that the 
Authentication keys are set. 

Setup  

 

W.2.14 Click OK. 

 

The Message dialog box disappears. Setup 

 

W.2.15 Click Close. 

 

The Hosts List window disappears. Setup 

 

W.2.16 Click Close. 

 

The Authentication Manager window 
disappears. 

Setup 

 

W.2.17 Select EXIT button from CDE. 

 

A Logout Confirmation window appears. Setup 
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W.2.18 Select OK. System exits and the DII COE LOGIN screen 
appears. 

Setup  

X 
4.28 Merge Host 

X.1 Run Merge On the Candidate Platform  

X.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Login as secman. 

The desktop appears. Setup 

 

X.1.2 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 

 

X.1.3 Double-click Merge Host in the 
Application Manager – SecAdm 
window.  

The MergeHost Tool dialog box appears with 
kpccp listed as the hostname of the New APM 
Domain Host and kpchost listed as the hostname 
of the Master APM Server. 

Circle one:  PASS / FAIL 

X.1.4 Click OK. An Input dialog box appears asking for the 
Master APM authentication key. 

Circle one:  PASS / FAIL 

 

X.1.5 Enter the master APM authentication key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

X.1.6 Click OK. A User Conflicts window appears. 

AcctCon is highlighted in the left panel. 

Circle one:  PASS / FAIL 
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X.1.7 Click use master. The red text noting the conflicts turns to black. Circle one:  PASS / FAIL 

 

X.1.8 Click Reset. The conflict is again indicated by red text. Circle one:  PASS / FAIL 

 

X.1.9 Click use new. The red text noting the conflicts turns to black. Circle one:  PASS / FAIL 

 

X.1.10 Click Apply. A check is displayed next to AcctCon and 
secman is highlighted in the left panel. 

Circle one:  PASS / FAIL 

 

X.1.11 Click use new. The red text noting the conflicts turns to black. Circle one:  PASS / FAIL 

 

X.1.12 Click Apply. A check is displayed next to secman and 
sysadmin is highlighted in the left pane. 

Circle one:  PASS / FAIL 

 

X.1.13 Click use master. The red text noting the conflicts turns to black. Circle one:  PASS / FAIL 

 

X.1.14 Click Apply. A check is displayed next to sysadmin and the 
right pane shows No more user conflicts. 

Circle one:  PASS / FAIL 

 

X.1.15 Click OK. A Group Conflicts window appears. 

GrpCon is highlighted in the left panel. 

Circle one:  PASS / FAIL 

 

X.1.16 Click Apply. A check is displayed next to GrpCon and admin 
is highlighted in the left pane. 

Circle one:  PASS / FAIL 
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X.1.17 Click Apply. A check is displayed next to admin and other is 
highlighted in the left panel. 

Circle one:  PASS / FAIL 

 

X.1.18 Click Apply. A check is displayed next to other and the right 
pane shows No more group conflicts. 

Circle one:  PASS / FAIL 

 

X.1.19 Click OK. A Profile Conflicts window appears. 
ProCon is highlighted in the left panel. 

Circle one:  PASS / FAIL 

 

X.1.20 Click use master. The red text noting the conflicts turns to black. Circle one:  PASS / FAIL 

 

X.1.21 Click Apply. A check is displayed next to ProCon and SA 
Default is highlighted in the left panel. 

Note: SA Default may not be listed; if not, skip 
to step X.1.24. 

Circle one:  PASS / FAIL 

 

X.1.22 Click use new. The red text noting the conflicts turns to black. Circle one:  PASS / FAIL 

 

X.1.23 Click Apply. A check is displayed next to SA Default and the 
right pane shows No more profile 
conflicts. 

Circle one:  PASS / FAIL 

 

X.1.24 Click OK. A MergeHost Confirmation window 
appears with the following message: 
Send commands to the Master APM 
Server now? 

Circle one:  PASS / FAIL 
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X.1.25 Click OK. The MergeHost Status dialog box displays 
Finished. 

Circle one:  PASS / FAIL 

 

X.1.26 Click OK. The MergeHost Status dialog box disappears. Circle one:  PASS / FAIL 

 

X.2 Cleanup   

X.2.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click APM Client. 

An Input dialog box appears asking for the APM 
master authentication key. 

Circle one:  PASS / FAIL 

 

X.2.2 Enter the master APM authentication key. Asterisks appear in the text box. Circle one:  PASS / FAIL 

 

X.2.3 Click OK. The Account and Profile Manager dialog 
box appears. 

Circle one:  PASS / FAIL 

 

X.2.4 Select user AcctCon. User AcctCon is highlighted. Circle one:  PASS / FAIL 

 

X.2.5 Select Edit > Delete. A Confirm window prompts for confirmation. Circle one:  PASS / FAIL 

 

X.2.6 Click Yes. A Status Summary window appears indicating 
the Account was successfully deleted. 

Circle one:  PASS / FAIL 
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X.2.7 Click OK. Control returns to the Account and Profile 
Manager dialog box. The entry for AcctCon has 
been removed from the Accounts tab. 

Circle one:  PASS / FAIL 

 

X.2.8 Click Profiles. The Profiles tab is displayed. Circle one:  PASS / FAIL 

 

X.2.9 Select ProCon. ProCon is highlighted. Circle one:  PASS / FAIL 

 

X.2.10 Select Edit > Delete. A Confirm window prompts for confirmation. Circle one:  PASS / FAIL 

 

X.2.11 Click Yes. A Status Summary window appears indicating 
the Profile was successfully deleted. 

Circle one:  PASS / FAIL 

 

X.2.12 Click OK. Control returns to the Account and Profile 
Manager dialog box. The entry for ProCon has 
been removed from the Profiles tab. 

Circle one:  PASS / FAIL 

 

X.2.13 Click Groups. The Groups tab is displayed. Circle one:  PASS / FAIL 

 

X.2.14 Select GrpCon. GrpCon is highlighted. Circle one:  PASS / FAIL 

 

X.2.15 Select Edit > Delete. A Confirm window prompts for confirmation. Circle one:  PASS / FAIL 
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X.2.16 Click Yes. A Status Summary window appears indicating 
the Profile was successfully deleted. 

Circle one:  PASS / FAIL 

 

X.2.17 Click OK. Control returns to the Account and Profile 
Manager dialog box. The entry for GrpCon has 
been removed from the Groups tab. 

Circle one:  PASS / FAIL 

 

X.2.18 Select File > Exit. An Exit confirmation window appears. Circle one:  PASS / FAIL 

 

X.2.19 Click Yes. The Account and Profile Manager 
dialog box disappears. 

Circle one:  PASS / FAIL 

 

X.2.20 Double-click Edit APM Configuration. The Edit APM Configuration window 
appears.  

Circle one:  PASS / FAIL 

X.2.21 In the Master Host text box, enter 
kpccp 

kpccp appears in the text box. Circle one:  PASS / FAIL 
 

X.2.22 Click Submit. A dialog box appears indicating:   

Operation completed successfully. 

Circle one:  PASS / FAIL 

 

X.2.23 Click OK. The dialog box and the Edit APM 
Configuration window disappear. 

Circle one:  PASS / FAIL 

 

X.2.24 Open a Terminal window. A Terminal window appears with a command 
line prompt. 

Circle one:  PASS / FAIL 

 

X.2.25 At the command prompt type  
su - 

The Password prompt appears. Circle one:  PASS / FAIL 
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X.2.26 At the Password prompt type the root 
password. 

The command prompt returns. Circle one:  PASS / FAIL 

 

X.2.27 At the command prompt type 
csh 

The command prompt returns. Circle one:  PASS / FAIL 

 

X.2.28 In the Terminal window, type  
cd /h/COE/Comp/APM/bin 

The command prompt returns.  

X.2.29 In the Terminal window, type  
./APM_BecomeOwnMaster 

The command prompt returns.  

X.2.30 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

 

Login as secman. 

The desktop appears. Setup 

 

X.2.31 Select Applications > Application 
Manager > DII_APPS > SecAdm. 

The Application Manager – SecAdm 
window appears. 

Setup 

 

X.2.32 Double-click Remove Host in the 
Application Manager – SecAdm 
window. 

The Remove Hosts window appears. Cleanup 

X.2.33 Double-click kpccp in the Keep panel. kpccp moves to the Remove panel. Cleanup 

 

X.2.34 Click Submit. An INFORMATIONAL MESSAGE dialog box 
appears indicating: APM Server reloaded 
successfully. 

Cleanup 
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X.2.35 Click OK. A Completed dialog box appears indicating that 
kpccp has been removed. 

Cleanup 

 

X.2.36 Click OK. The dialog box and Remove Hosts window 
disappear. 

Cleanup 

 

X.2.37 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Cleanup 

 

X.2.38 NOTE: Perform the following steps on the 
Validation Host (kpchost).  

Log in as user keyman. 

The desktop appears.  
 

Setup  

X.2.39 Select Applications > Application 
Manager > DII_APPS > APM > 
Authentication Manager. 

The Authentication Manager window 
appears. 

Setup  

X.2.40 Enter the master authentication key in the Key text 
box. 

Asterisks appear in the text box. Cleanup 

 

X.2.41 Click Set Client’s Local Key. The Hosts List window appears. Cleanup 

 

X.2.42 Select kpccp. kpccp is highlighted. Cleanup 
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X.2.43 Select Delete Host. A Confirm dialog box appears with the 
following message: 
Delete the local authentication 
keys of these hosts? 

kpccp 

Cleanup 

X.2.44 Click Yes. The dialog box disappears. Cleanup 

 

X.2.45 Click Close in the Hosts List window. The Hosts List window disappears. Cleanup 

 

X.2.46 Click Close in the Authentication 
Manager window. 

The Authentication Manager window 
disappears. 

Cleanup 

X.2.47 Log out of the Validation Host (kpchost). The DII COE LOGIN screen appears. Cleanup 

 

Y 
4.29 Profile Selector Config 

Y.1 Setup  

Y.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Double-click Profile Selector Config. 

The Profile Selector Configuration 
dialog box appears. 

Circle one:  PASS / FAIL 

Y.1.2 Click Cancel. The Profile Selector Configuration 
dialog box disappears. 

Circle one:  PASS / FAIL 
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Z 
4.30 Remove Host 

Z.1 Setup  

Z.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

Double-click Remove Host. 

The Remove Hosts dialog box appears. Circle one:  PASS / FAIL 

Z.1.2 Click Cancel. The Remove Hosts dialog box disappears. 

 

Circle one:  PASS / FAIL 

Z.1.3 Select EXIT button from CDE. 

 

A Logout Confirmation window appears. Circle one:  PASS / FAIL 

Z.1.4 Select OK. System exits and the DII COE LOGIN screen 
appears. 

Circle one:  PASS / FAIL 

 

AA 
4.31 Public Key Manager 

AA.1 Setup  

AA.1.1 NOTE: Perform the following steps on the 
Candidate Platform (kpccp). 

 

Login as keyman. 

The desktop appears.  
 

Setup 

 

AA.1.2 Select Applications > Application 
Manager > DII_APPS > APM > Public 
Key Manager. 

The Public Key Manager window appears. Circle one:  PASS / FAIL 
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AA.1.3 Click Cancel. The Public Key Manager window 
disappears. 

Circle one:  PASS / FAIL 

ZZ 
4.32 Logout 

ZZ.1 Verify Logout  

ZZ.1.1 Select EXIT button from CDE. 

 

A Logout Confirmation window appears. Circle one:  PASS / FAIL 

ZZ.1.2 Select OK. System exits and the DII COE LOGIN screen 
appears. 

Circle one:  PASS / FAIL 

 
 

End of Validation Procedure 
 

 
 

 
 

 

 

 

 


